Data dodania Pytanie
2018-01-06 20:01 No matching version found for require-from-string@^1.1.0 »
Dependencies for npm project: "dependencies": { "angular-chart.js": "1.1.0", "angular-cookies": "1.5.7", "angular-ui-bootstrap": "2.4.0",...
(3) odpowiedzi
2017-11-24 09:11 Error: npm install -g @angular/cli »
When I am trying to run this command, it through error and NPM does not install completely. Before this version of Node.js I also installed node-v8.9...
(2) odpowiedzi
2017-09-28 17:09 node: relocation error: node: symbol SSL_set_cert_cb, version libssl.so.10 not defined in file libssl.so.10 with link time reference »
I've been running a NodeJS server for a website using the MEAN stack for a website, and it's been running for a few months. When I started to work on ...
(1) odpowiedzi
2017-09-27 07:09 Can't install node modules globally. Module not found error »
I am trying to install modules globally using npm but the command is always failing. I used npm already in the past and it worked without problems. No...
(3) odpowiedzi
2017-09-03 11:09 npm - Error: EPERM: operation not permitted, unlink »
Windows 10 1703 Node 6.11.2 npm 5.4.0 Everytime I try to install an npm package (ex: npm i gulp-notify), I receive the following error: npm ERR!...
(1) odpowiedzi
2017-08-20 22:08 Using react-native-fbsdk with react-native 0.42 »
When I try to install react-native-fbsdk I'm getting: +-- UNMET PEER DEPENDENCY react-native@0.42.0 `-- react-native-fbsdk@0.6.1 react-native-fbsdk@...
(0) odpowiedzi
2017-08-07 21:08 Forked repo doesn't add itself to .bin »
Running yarn add graphql-typewriter adds symlink to an executable inside node_modules/.bin/. However, running the same command on a forked version of ...
(1) odpowiedzi
2017-07-15 13:07 What does "requires: true" do in package-lock.json »
Our team just updated to npm@5. The package-lock.json was unified between Windows and Mac (certain dependencies are optional so they don't get install...
(1) odpowiedzi
2017-07-10 23:07 Why does "npm install" rewrite package-lock.json? »
I just recently upgraded to npm@5. I now have a package-lock.json file with everything from package.json. I would expect that, when I run npm instal...
(1) odpowiedzi
2017-05-03 23:05 Two versions of same npm package in Node application »
I'm working on a CLI tool in NodeJS that uses another NodeJs package that we develop, which is an SDK. The thing is, we just published a V2 version ...
(1) odpowiedzi
2017-03-28 19:03 error in webpack compiling »
I've got an error while I'm trying to run my angular2 project. It occured after switching from PC with ubuntu to MacOS X. Node version: 7.7.4, npm ver...
(1) odpowiedzi
2017-02-03 14:02 npm3 install breaks the flat structure if installing module from local folder »
I have the following dependency tree: module_a@1.9.15 module_b@1.0.22 module_c@1.1.2 module_b@1.0.22 (The important part is that m...
(0) odpowiedzi
2017-01-07 04:01 UNMET PEER DEPENDENCY D3.js and Angular 2 »
I have an existing Angular 2 project, and I'm trying to get started integrating some D3.js into my project. I'm new to Angular, and this will be my fi...
(2) odpowiedzi
2016-11-29 07:11 Is there a way to install all npm dependencies globally (centrally) so that you do not store node_modules in the project folder? »
This is causing problems with my computer as I have over 40 projects each with their own node_modules folder, packed with millions of 1kb files. I a...
(0) odpowiedzi
2016-11-23 01:11 Can't install any packages to NPM or BOWER »
I have researched this extensively and nothing. So I am hoping this generates a different solution. I keep getting this error npm WARN packages@1.0....
(1) odpowiedzi
2016-10-10 20:10 Nativescript:Oauth Not working »
I am trying to create a Facebook Oauth System for my NativeScript Android App.I have installed nativescript-oauth from my app's folder directory like ...
(0) odpowiedzi
2016-10-06 11:10 what's the difference between "npm install" and "npm --userconfig=./.npmrccorp i " »
I want to know what the difference is between these two commands in nodejs npm install and, npm --userconfig=./.npmrccorp i As fa...
(2) odpowiedzi
2016-09-02 04:09 React Native component dependency which requires rnpm link »
I just created a component for React-Native that I will push soon to npm as a package. Although I'm facing an issue. The component is dependent of an...
(1) odpowiedzi
2016-08-26 09:08 Node modules issue: Only one default export allowed per module »
This a issue we faced while doing an npm install on server which loaded new set of version for node_modules. We have a module which looks like expo...
(1) odpowiedzi
2016-08-14 11:08 Find the dependency that brought another dependency in Node.js »
Now that npm installs dependencies in a flat structure the node_modules dir is crowded with lots and lots of dependencies and I have a hard time traci...
(2) odpowiedzi
2016-08-01 08:08 Create local npm package with local dependencies and install it in another package »
I have created three different custom modules. getcorrespondence-1.0.0.tgz getrediscache-1.0.0.tgz setrediscache-1.0.0.tgz I have created these cu...
(0) odpowiedzi
2016-07-12 05:07 Configure existing project on reactJS »
I am a newbie to all reactJS and node so my question is pretty basic. I have downloaded an already existing project in gitlab using gitbash on my wind...
(2) odpowiedzi
2016-06-11 05:06 How Does One Include Bootstrap in Node Project »
I have a MEAN stack project that was scaffolded using the basic npm command. At the moment, the Bootstrap is included using CDN: link(rel='stylesheet...
(1) odpowiedzi
2016-05-20 14:05 How to fix 'fs: re-evaluating native module sources is not supported' - graceful-fs »
Recently I've made a switch to Node v.6, and It started creating more and more problems with running normal builds grunt/gulp/webpack For example: $...
(2) odpowiedzi
2016-05-05 09:05 npm install not reading package.json »
not sure what's going on but I have a box running on ubuntu through digital ocean and just cloned my git repo. I have a package.json that is correctly...
(1) odpowiedzi
2016-04-21 18:04 Functions may not be defined within control directives or other mixins »
In my nodeJS project suddenly it give error.I do not any upgrade or changes. When I write NPM start in command line it give that error ERROR in ./~/...
(3) odpowiedzi
2016-04-13 21:04 Download latest compatible module »
The only questions I found in my search yielded upgrading NPM modules to the latest. Is there a way to make it so NPM downloads the latest compatible...
(0) odpowiedzi
2016-03-12 15:03 sails.js + npm module 'bcrypt' is not installing in windows 10 »
I have cloned a sails project which is using 'bcrypt' module and when i am trying to install it using command - npm install --save bcrypt but i...
(1) odpowiedzi
2016-02-12 21:02 NPM install fails inside Docker container but runs on host w/ corporate proxy »
I am deploying some node.js services to a corporate system within docker containers. My Dockerfiles for these services are very basic, with the excep...
(1) odpowiedzi