Question: How can I deploy this Ruby/Sinatra app to Heroku?

Question

How can I deploy this Ruby/Sinatra app to Heroku?

Answers 1
Added at 2016-12-27 21:12
Tags
Question

I'm trying to do my very first Ruby/Sinatra deploy (yay!), a "to do list" app website to Heroku. The code runs fine in Windows and Ubuntu environments

My humble app

but I'm having trouble actually successfully deploying.

I tried following this tutorial using my own code. When I execute sudo git push heroku master, I'm told the app is deployed to Heroku, but when I go to the URL it gives, it's not running. I might need help with my (one-line) Procfile. Also, a "warning" (does that mean deployment didn't happen?) says I didn't declare my Ruby version. I tried using rvm 2.2.5 and putting gem 'ruby', '2.2.5' in my Gemfile, but the bundler won't install if I declare a Ruby version (it says I don't have that version of Ruby installed, which I certainly seem to).

sudo git push heroku master
Counting objects: 5, done.
Compressing objects: 100% (4/4), done.
Writing objects: 100% (5/5), 419 bytes | 0 bytes/s, done.
Total 5 (delta 3), reused 1 (delta 0)
remote: Compressing source files... done.
remote: Building source:
remote: 
remote: -----> Ruby app detected
remote: -----> Compiling Ruby/Rack
remote: -----> Using Ruby version: ruby-2.2.6
remote: -----> Installing dependencies using bundler 1.13.6
remote:        Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment
remote:        Warning: the running version of Bundler (1.13.6) is older than the version that created the lockfile (1.13.7). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.
remote:        Fetching gem metadata from https://rubygems.org/.........
remote:        Fetching version metadata from https://rubygems.org/.
remote:        Using diff-lcs 1.2.5
remote:        Using rack 1.6.5
remote:        Using rspec-support 3.5.0
remote:        Using ruby 0.1.0
remote:        Using tilt 2.0.5
remote:        Using bundler 1.13.6
remote:        Using rspec-core 3.5.4
remote:        Using rspec-expectations 3.5.0
remote:        Using rspec-mocks 3.5.0
remote:        Using rack-protection 1.5.3
remote:        Using sinatra 1.4.7
remote:        Bundle complete! 7 Gemfile dependencies, 11 gems now installed.
remote:        Gems in the groups development and test were not installed.
remote:        Bundled gems are installed into ./vendor/bundle.
remote:        Bundle completed (1.79s)
remote:        Cleaning up the bundler cache.
remote:        Warning: the running version of Bundler (1.13.6) is older than the version that created the lockfile (1.13.7). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.
remote:        Removing dbm (0.5)
remote: -----> Detecting rake tasks
remote: 
remote: ###### WARNING:
remote:        You have not declared a Ruby version in your Gemfile.
remote:        To set your Ruby version add this line to your Gemfile:
remote:        ruby '2.2.6'
remote:        # See https://devcenter.heroku.com/articles/ruby-versions for more information.
remote: 
remote: -----> Discovering process types
remote:        Procfile declares types     -> web
remote:        Default types for buildpack -> console, rake
remote: 
remote: -----> Compressing...
remote:        Done: 17.3M
remote: -----> Launching...
remote:        Released v5
remote:        https://gentle-sea-73583.herokuapp.com/ deployed to Heroku
remote: 
remote: Verifying deploy... done.
To https://git.heroku.com/gentle-sea-73583.git
   995b763..014acd8  master -> master

I also tried executing sudo heroku run ruby todo.rb (todo.rb is my server app), and I get this:

sudo heroku run ruby todo.rb
Running ruby todo.rb on ⬢ gentle-sea-73583... up, run.3103 (Free)
/app/vendor/ruby-2.2.6/lib/ruby/2.2.0/yaml/dbm.rb:2:in `require': cannot load such file -- dbm (LoadError)
    from /app/vendor/ruby-2.2.6/lib/ruby/2.2.0/yaml/dbm.rb:2:in `<top (required)>'
    from /app/lib/task_store.rb:2:in `require'
    from /app/lib/task_store.rb:2:in `<top (required)>'
    from todo.rb:7:in `require'
    from todo.rb:7:in `<main>'

Maybe I need to set up YAML on Heroku somehow? I don't see how though...

Answers to

How can I deploy this Ruby/Sinatra app to Heroku?

nr: #1 dodano: 2016-12-27 22:12

Remove gem 'dbm' from your Gemfile.

That dbm gem only works with jruby and you don't need it since you are using yaml/dbm.

Source Show
◀ Wstecz