Question: Mongoose - deprecated mongodb@2.2.16: Please upgrade to 2.2.19 or higher?

Question

Mongoose - deprecated mongodb@2.2.16: Please upgrade to 2.2.19 or higher?

Answers 1
Added at 2017-01-04 11:01
Tags
Question

Why do I keep getting this warning message below when I try to install mongoose?

npm WARN deprecated mongodb@2.2.16: Please upgrade to 2.2.19 or higher

json:

{
  "name": "dummy-app",
  "version": "0.0.0",
  "private": true,
  "scripts": {
    "start": "node ./bin/www"
  },
  "dependencies": {
    "body-parser": "~1.15.1",
    "cookie-parser": "~1.4.3",
    "debug": "~2.2.0",
    "express": "~4.13.4",
    "pug": "~2.0.0-beta3",
    "morgan": "~1.7.0",
    "serve-favicon": "~2.3.0",
    "mongoose": "^4.7.6"
  }
}

How can I fix that?

Answers to

Mongoose - deprecated mongodb@2.2.16: Please upgrade to 2.2.19 or higher?

nr: #1 dodano: 2017-01-04 12:01

The npm package mongodb is a dependency of mongoose: it is automatically installed by npm when you install mongoose.

mongoose v4.7.6 depends on mongodb 2.2.16 (see its package.json file), but there is a newer bugfix release available (2.2.19) which is why you see the warning.

As mongodb is a dependency of mongoose, you will have to wait for a mongoose maintainer to update the dependency: this is not an issue you have to fix in your code.

As a matter of fact, this issue is already tracked in mongoose's Github here.

Source Show
◀ Wstecz