Question: ERROR import with CocoaPods

Question

ERROR import with CocoaPods

Answers 2
Added at 2017-01-04 02:01
Tags
Question

I just installed CocoaPods so I'll be able to import the Facebook SDK for Swift

When I install the pod I got this warning:

error

[!] The MyAppName[Release] target overrides the FRAMEWORK_SEARCH_PATHS build setting defined in `Pods/Target Support Files/Pods-myappname/Pods-myappname.release.xcconfig'. This can lead to problems with the CocoaPods installation

I already did all the solution listed in this post but didn't work for me.

When I use $(inherited) the field remain white: error2

And my Facebook import don't work:

No such module as 'FacebookCore'

Where is the problem? I'm going mad.

Here is my Pod file:

error3

EDIT FOR THE ANSWER:

I edited the file like that and run the command but got the same warning and my import still don't work:

error4

Answers
nr: #1 dodano: 2017-01-04 03:01

EDIT

Use the `$(inherited)` flag

  1. Go to project > TARGETS > target > Build Settings
  2. Search for FRAMEWORK_SEARCH_PATHS
  3. add $(inherited) to each configuration

    Adding the inherited flag

  4. Quit Xcode
  5. rm -rf Pods/ Podfile.lock ; pod install

If this fails, clean the configurations as well:

  1. Go to project > PROJECT > Info > Configurations, select each one, one at a time (Debug, ApplicationUnitTest, Release, etc.), and for each target within said configuration, set configuration to None.
    Make certain that Based on Configuration File reads 0 Configurations Set
  2. Quit Xcode
  3. rm -rf Pods/ Podfile.lock ; pod install
nr: #2 dodano: 2017-01-04 12:01

Thanks for contributing, The only way I found that work is to re-create a new Project and start on from there.

Any work around didn't work for me.

Source Show
◀ Wstecz