Question: Unsupported Swift Version

Question

Unsupported Swift Version

Answers 0
Added at 2017-09-06 18:09
Tags
Question

I am following this tutorial and am trying to get the starter project to run. When I open the project, I see these warnings:

Unsupported Swift Version
The target “SocketChat” contains source code developed with Swift 2.x. Xcode 9 does not support building or migrating Swift 2.x targets.

Use Xcode 8.x to migrate the code to Swift 3.

On running this program stops executions and I get this error

Dependency Analysis Error Group
The “Swift Language Version” (SWIFT_VERSION) build setting must be set to a supported value for targets which use Swift. This setting can be set in the build settings editor.

I am using Xcode 9 beta. How can I resolve this issue and get the project running?

Answers to

Unsupported Swift Version

Source Show
◀ Wstecz